MK808 newest firmware release

Re: MK808 newest firmware release

Postby BooLE » Fri Nov 02, 2012 12:56 pm

garyb wrote:
OK FreakTab user Boole told me to take another look at the ROM I downloaded last night. I did a binary file compare. The kernel is the same date. However some system files are in fact different. System date is 10/27 not 10/26.

So in fact I have a new ROM. Again very few files changes (17 different files).

I do not have a lot of time to test everything but the reboot APP no longer causes the system to corrupt. So that is a good sign! You guys will have to help me test everything. I just want you all to have a new ROM as soon as possible this time since everyone is waiting.

So stay tuned.... New ROM today!

Bob


garyb you are fast :lol: :lol:
BooLE
 
Posts: 61
Joined: Tue Sep 25, 2012 9:41 am

Re: MK808 newest firmware release

Postby deadhp1 » Fri Nov 02, 2012 1:50 pm

Can you try the following commands in terminal?
Code: Select all
su
iwconfig wlan0 rate 65 fixed
iwconfig wlan0 power off

This should set the bitrate to 65mbs and turn off power management. For me this keeps it steady at 65mbs. Before entering those commands I get speeds that change back and forth.


jefflessard wrote:
geekbuying wrote:guys,i need you do a favor for me.

I report the wifi drop problem to factory, they want to know the problem in detail, because we already tested the mk808, we watch online tv online,and we don't find the wifi drops all the time.

please send me PM with the detail,if someone can offer me a video to check the wifi drops problems, tell me how long it will last when it drops, more details will help factory to find the problem, and solve them!!

thanks


Hi geekbuying,

Here is an example of the problem I experience with the WiFi. The first screenshot has been taken just after turning the WiFi on. The second screenshot has been taken after trying 5 minutes of NAS streaming using Skifta.

2012-11-01-18-23-44.png-959498982.png


2012-11-01-18-28-31.png1150440244.png


Bit Rate as dropped from 65 Mb/s to 5.5 Mb/s
66 packets have been received with invalid encryprion
12 packets were abandoned due to excessive sending retries
I guess there is no need to mention that streaming was now working really great ;)

Screenshots where taken using iwconfig command line:
iwconfig.txt-51191670.txt

(Rename to iwconfig and chmod +x)
deadhp1
 
Posts: 659
Joined: Thu Sep 20, 2012 5:22 pm

Re: MK808 newest firmware release

Postby deadhp1 » Fri Nov 02, 2012 2:01 pm

I have the BETA 2 firmware also. I just need to check with Geekbuying to make sure it's okay to release it.
It doesn't fix much which is why we hadn't released it yet.

It fixes the system corrupt when using the reboot app.
It also seems to fix the cpu governors that they are all able to go up to ~1400Mhz and can be set by SetCPU.

I have also created a version that is rooted and has SuperSU and RootExplorer installed.
deadhp1
 
Posts: 659
Joined: Thu Sep 20, 2012 5:22 pm

Re: MK808 newest firmware release

Postby fxpilot » Fri Nov 02, 2012 2:11 pm

deadhp1 thanks :) hope you can release my mk808 has corrupted the internal sdcard not mountable
fxpilot
 
Posts: 49
Joined: Fri Sep 28, 2012 12:25 pm

Re: MK808 newest firmware release

Postby BooLE » Fri Nov 02, 2012 3:02 pm

deadhp1 wrote:I have the BETA 2 firmware also. I just need to check with Geekbuying to make sure it's okay to release it.
It doesn't fix much which is why we hadn't released it yet.

It fixes the system corrupt when using the reboot app.
It also seems to fix the cpu governors that they are all able to go up to ~1400Mhz and can be set by SetCPU.

I have also created a version that is rooted and has SuperSU and RootExplorer installed.


Since I got it directly from Tomato, and not through geekbuying, I don't see a problem for you to release it public. I would do it already, but I have very limited upload bandwidth, so it would take ages for me.
BooLE
 
Posts: 61
Joined: Tue Sep 25, 2012 9:41 am

Re: MK808 newest firmware release

Postby deadhp1 » Fri Nov 02, 2012 3:07 pm

Alright Here they are. Keep in mind I name the files slightly different.
Stock Beta 2 Download beta_JB_04.zip from ultramegabit.com:
http://ultramegabit.com/file/details/rCVsOCeYN5o

Rooted with SuperSU and RootExplorer Download rooted_JB_beta_4.zip from ultramegabit.com:
http://ultramegabit.com/file/details/AHKjYcRUs68
deadhp1
 
Posts: 659
Joined: Thu Sep 20, 2012 5:22 pm

Re: MK808 newest firmware release

Postby danielepiras » Fri Nov 02, 2012 6:09 pm

thank you deadhp1!
well done!
I have try the new rom and the corruption bug seems solved!
thank you vey much for your work..
danielepiras
 
Posts: 3
Joined: Wed Oct 31, 2012 8:59 am

Re: MK808 newest firmware release

Postby jefflessard » Fri Nov 02, 2012 8:16 pm

Thank you for your suggestion... but it doesn't really help!

deadhp1 wrote:Can you try the following commands in terminal?
Code: Select all
su
iwconfig wlan0 rate 65 fixed
iwconfig wlan0 power off

This should set the bitrate to 65mbs and turn off power management. For me this keeps it steady at 65mbs. Before entering those commands I get speeds that change back and forth.


jefflessard wrote:
geekbuying wrote:guys,i need you do a favor for me.

I report the wifi drop problem to factory, they want to know the problem in detail, because we already tested the mk808, we watch online tv online,and we don't find the wifi drops all the time.

please send me PM with the detail,if someone can offer me a video to check the wifi drops problems, tell me how long it will last when it drops, more details will help factory to find the problem, and solve them!!

thanks


Hi geekbuying,

Here is an example of the problem I experience with the WiFi. The first screenshot has been taken just after turning the WiFi on. The second screenshot has been taken after trying 5 minutes of NAS streaming using Skifta.

2012-11-01-18-23-44.png-959498982.png


2012-11-01-18-28-31.png1150440244.png


Bit Rate as dropped from 65 Mb/s to 5.5 Mb/s
66 packets have been received with invalid encryprion
12 packets were abandoned due to excessive sending retries
I guess there is no need to mention that streaming was now working really great ;)

Screenshots where taken using iwconfig command line:
iwconfig.txt-51191670.txt

(Rename to iwconfig and chmod +x)
jefflessard
 
Posts: 14
Joined: Mon Oct 15, 2012 6:17 pm

Re: MK808 newest firmware release

Postby fxpilot » Fri Nov 02, 2012 11:00 pm

Thanks deadhp1 for wifi info,
so far mine is at least usable were I could not even use it, it still drops out but not as often.

1) iwconfig wlan0 power off
2) installed regpon from market "to keep connection alive
3) wake lock from market
4) router set to channel 7

Is there any way to make it keep the ( iwconig wlan0 power off ) so it auto loads this at boot?
fxpilot
 
Posts: 49
Joined: Fri Sep 28, 2012 12:25 pm

Re: MK808 newest firmware release

Postby kmunir » Sat Nov 03, 2012 2:20 am

Thanks to deadhp1 and geekbuying and bob again. I am having a slight issue with this update 4 beta. Hd videos in YouTube are buffering a lot which didn't use to happen before. Is anyone else having the same problem? I am using deadhp1's rooted update 4 firmware
kmunir
 
Posts: 75
Joined: Wed Sep 26, 2012 11:48 am

PreviousNext

Return to MK808

Who is online

Users browsing this forum: Google Feedfetcher and 2 guests

cron