bricked mx1?

bricked mx1?

Postby csmcpb » Sat Nov 10, 2012 4:27 am

Hi after updating to the latest firmware via the geekbuying website I have now got stuck at the imito opening screen, the device rebooted after flashing the firmware and will not go any further! Any one know if there is a recovery mode on this device? Hopefully all is Ok as it seemed like a stable device before this! :cry:
csmcpb
 
Posts: 3
Joined: Fri Nov 09, 2012 4:31 pm

Re: bricked mx1?

Postby qsecofr » Sat Nov 10, 2012 9:18 am

csmcpb wrote:Hi after updating to the latest firmware via the geekbuying website I have now got stuck at the imito opening screen, the device rebooted after flashing the firmware and will not go any further! Any one know if there is a recovery mode on this device? Hopefully all is Ok as it seemed like a stable device before this! :cry:


Did the update finish correct?
Try to start it with the AC-adapter instead of usb to PC.
I have read somewhere that ppl are having trouble sometimes booting android mini pc with just usb to PC.

Mine did start after update powered just from the PC, but it can't hurt to try with the AC-adapter.
qsecofr
 
Posts: 42
Joined: Tue Nov 06, 2012 5:19 am

Re: bricked mx1?

Postby csmcpb » Sat Nov 10, 2012 10:35 am

Yeah was all done with the ac adaptor plugged in and the update appeared to finish Ok although the batch tool I used was in Chinese so may of gone wrong somewhere!
csmcpb
 
Posts: 3
Joined: Fri Nov 09, 2012 4:31 pm

Re: bricked mx1?

Postby qsecofr » Sat Nov 10, 2012 10:46 am

csmcpb wrote:Yeah was all done with the ac adaptor plugged in and the update appeared to finish Ok although the batch tool I used was in Chinese so may of gone wrong somewhere!


Ok, maybe that was wrong to use the ac adaptor plugged in as well?
I think the guide says just to use the OTG port at the side when you are flashing.

At least that was the way i did it without any problems.

You can run the tool i n English if you rename the folder that contains the flash tool to something with western characters, like 'tool' ore something.
Then you can press the button in the lower left corner to change language. A little bit late now perhaps.

I really hope you can get it going again, for sure there is a way to force it in recovery or download mode.
But it might be so that you have to open it up and short some pins on the board to force it.

I hope someone else knows how to do it.

Cheers.
qsecofr
 
Posts: 42
Joined: Tue Nov 06, 2012 5:19 am

Re: bricked mx1?

Postby geekbuying » Tue Nov 13, 2012 10:39 am

Hi

sorry for answering this question late.

I have found your problem and talked with factory, they also have method for how to fix the failed update, i have asked them to give me an instruction,and then i will post here for you,please don't worry, your MX1 still can alive. lol
Black Friday--Shopping Carnival with $0.01 Flash Deal & Half Price Deal-->> See

Skype: marketing-gkb
Help & GET Coupon--E-mail: cooperation@geekbuying.com
User avatar
geekbuying
 
Posts: 349
Joined: Wed Sep 26, 2012 10:11 am

Re: bricked mx1?

Postby Finlessbob » Tue Nov 13, 2012 11:54 am

The MX1 has the same shorting pads that the ug802 has to reset the processor into MASK ROM mode to unbrick. You have to take it apart to short those pads.
One little screw hols the back plastic plate on. Then pop that off. Now push the board out of the case. Under the Wifi Antenna are the 2 shorting pads just like the ug802. See the ug802 unbrick instrucitons for how to do it.

Bob
Finlessbob
 
Posts: 30
Joined: Wed Sep 26, 2012 11:30 am

Re: bricked mx1?

Postby reddragon72 » Tue Nov 13, 2012 12:44 pm

I don't think he has to go that far. a bricked phone never does anything. For his situation is sounds like a boot loop. Have you tried to reflash? And as always ROM providers need to provide an MD5 check so you can ensure you has a complete download as you can still flash a corrupted ROM.

So go and ask your rom provider to give you an MD5 check sum and then run a MD5 checksum on your rom. Once you confirm that it is good then try and reflash as you should be able to get back into the flash mode. If you cannot then by all means do the jumper, but do it with caution.
reddragon72
 
Posts: 103
Joined: Wed Oct 31, 2012 2:30 pm

Re: bricked mx1?

Postby jvbo » Thu Dec 06, 2012 6:58 pm

Mine has the same problem. Stuck with the iMito logo.

There has to be a way to do a factory reset!

Waiting for a solution...
jvbo
 
Posts: 4
Joined: Thu Dec 06, 2012 6:55 pm

Re: bricked mx1?

Postby enviro8 » Thu Dec 06, 2012 10:41 pm

When I was playing around with some firmware that I modded, I was stuck with the Android logo on the screen.

I simply reflashed the MX1with a known working ROM using the method in http://blog.geekbuying.com/index.php/20 ... -firmware/

The MX1 is supposed to have mass storage active and USB debugging off. Since mine wouldn't boot, I went in blind and followed the instructions.

It worked!

I would recommend giving this a try before dismantling the dongle.
enviro8
 
Posts: 25
Joined: Sat Nov 03, 2012 7:23 pm

Re: bricked mx1?

Postby enviro8 » Fri Dec 07, 2012 1:10 am

How To Restore iMiTO MX1 Firmware

To escape from the brick due to an update failure you need to reload a working ROM firmware.

I have used the following method with iMiTO AM801 Tablet and have now trialled it with the iMiTO MX1 now that I have received a HDMI cable connector.

Firstly you will need a known working firmware.

Next find and download “Rockchip_Batch_Tool_v1.5.zip”.

Unzip it and move your firmware to where you can find it easily and rename it “update.img”.

Connect the MX1 to your TV but with the power disconnected.

There is a small hole next to the HDMI connector on the end of the MX1. This is a Reset.

Getting the Driver

If you already have the driver installed, you may skip this step.
Insert and hold in with a paper clip or equivalent and while still holding it in, connect to your PC via the USB OTG socket.

Your PC will find and try to install a new USB device. This will take some time. You may be lucky and it will install as something like RK30. Most likely it will fail. You will then need to open Computer (in Windows 7) and click on System properties --> Device manager.

In there you will see an error.

Click on the error and click on Driver and then click on Update Driver.
Click on Browse for driver software and click on Let me pick from a list of drivers
Click on Have Disk and navigate to where you have unzipped the Rockchip Batch Tool. In there you will find a folder called RockusbDriver open it and drill down to the drivers that match your system.
Click on and install the appropriate driver.

Installing your ROM

Go to where you unzipped the Rockchip Batch Tool and run RKBatchTool.exe.

With the power disconnected, insert a paper clip into the reset and hold it in. Connect the MX1 to your PC via a USB connected to the MX1’s OTG mini USB socket.

If everything is OK, then the box numbered 1 will light green.

Go to FW Path: at the top and click on the box in the top right.

Navigate to your firmware and open it. The program will check the firmware and report if there is a problem.

Then click on Restore and the firmware will be installed after a while. If everything is OK a message will pop up confirming success or failure.

Your MX1 will then reboot and load up.

NOTE: The TV screen will remain blank through the above process.

Good Luck!
enviro8
 
Posts: 25
Joined: Sat Nov 03, 2012 7:23 pm

Re: bricked mx1?

Postby jvbo » Mon Dec 10, 2012 12:04 pm

enviro8 wrote:How To Restore iMiTO MX1 Firmware

To escape from the brick due to an update failure you need to reload a working ROM firmware.

I have used the following method with iMiTO AM801 Tablet and have now trialled it with the iMiTO MX1 now that I have received a HDMI cable connector.

Firstly you will need a known working firmware.

Next find and download “Rockchip_Batch_Tool_v1.5.zip”.

Unzip it and move your firmware to where you can find it easily and rename it “update.img”.

Connect the MX1 to your TV but with the power disconnected.

There is a small hole next to the HDMI connector on the end of the MX1. This is a Reset.

Getting the Driver

If you already have the driver installed, you may skip this step.
Insert and hold in with a paper clip or equivalent and while still holding it in, connect to your PC via the USB OTG socket.

Your PC will find and try to install a new USB device. This will take some time. You may be lucky and it will install as something like RK30. Most likely it will fail. You will then need to open Computer (in Windows 7) and click on System properties --> Device manager.

In there you will see an error.

Click on the error and click on Driver and then click on Update Driver.
Click on Browse for driver software and click on Let me pick from a list of drivers
Click on Have Disk and navigate to where you have unzipped the Rockchip Batch Tool. In there you will find a folder called RockusbDriver open it and drill down to the drivers that match your system.
Click on and install the appropriate driver.

Installing your ROM

Go to where you unzipped the Rockchip Batch Tool and run RKBatchTool.exe.

With the power disconnected, insert a paper clip into the reset and hold it in. Connect the MX1 to your PC via a USB connected to the MX1’s OTG mini USB socket.

If everything is OK, then the box numbered 1 will light green.

Go to FW Path: at the top and click on the box in the top right.

Navigate to your firmware and open it. The program will check the firmware and report if there is a problem.

Then click on Restore and the firmware will be installed after a while. If everything is OK a message will pop up confirming success or failure.

Your MX1 will then reboot and load up.

NOTE: The TV screen will remain blank through the above process.

Good Luck!


Worked for me!!

Thanks!
jvbo
 
Posts: 4
Joined: Thu Dec 06, 2012 6:55 pm

Re: bricked mx1?

Postby Kzn » Mon Dec 24, 2012 3:45 am

You're my Santa Claus, thank you enviro8 !
Kzn
 
Posts: 2
Joined: Mon Dec 24, 2012 3:00 am

Re: bricked mx1?

Postby tonberry » Tue Jan 08, 2013 7:21 pm

enviro8 wrote:How To Restore iMiTO MX1 Firmware

To escape from the brick due to an update failure you need to reload a working ROM firmware.

I have used the following method with iMiTO AM801 Tablet and have now trialled it with the iMiTO MX1 now that I have received a HDMI cable connector.

Firstly you will need a known working firmware.

Next find and download “Rockchip_Batch_Tool_v1.5.zip”.

Unzip it and move your firmware to where you can find it easily and rename it “update.img”.

Connect the MX1 to your TV but with the power disconnected.

There is a small hole next to the HDMI connector on the end of the MX1. This is a Reset.

Getting the Driver

If you already have the driver installed, you may skip this step.
Insert and hold in with a paper clip or equivalent and while still holding it in, connect to your PC via the USB OTG socket.

Your PC will find and try to install a new USB device. This will take some time. You may be lucky and it will install as something like RK30. Most likely it will fail. You will then need to open Computer (in Windows 7) and click on System properties --> Device manager.

In there you will see an error.

Click on the error and click on Driver and then click on Update Driver.
Click on Browse for driver software and click on Let me pick from a list of drivers
Click on Have Disk and navigate to where you have unzipped the Rockchip Batch Tool. In there you will find a folder called RockusbDriver open it and drill down to the drivers that match your system.
Click on and install the appropriate driver.

Installing your ROM

Go to where you unzipped the Rockchip Batch Tool and run RKBatchTool.exe.

With the power disconnected, insert a paper clip into the reset and hold it in. Connect the MX1 to your PC via a USB connected to the MX1’s OTG mini USB socket.

If everything is OK, then the box numbered 1 will light green.

Go to FW Path: at the top and click on the box in the top right.

Navigate to your firmware and open it. The program will check the firmware and report if there is a problem.

Then click on Restore and the firmware will be installed after a while. If everything is OK a message will pop up confirming success or failure.

Your MX1 will then reboot and load up.

NOTE: The TV screen will remain blank through the above process.

Good Luck!


Wow! Thank you so much for these clear instructions.
You've just saved me from throwing my newly arrived iMiTO MX2 out the window!!!
thank you enviro8.
tonberry
 
Posts: 1
Joined: Sat Jan 05, 2013 7:50 pm

Re: bricked mx1?

Postby deepmind » Sun Jan 13, 2013 3:32 pm

Hi,
I bricked my iMito MX1. It loops at boot (at "iMito MX series" text). I followed the instructions how to unbrick it, but no luck so far.
I previously successfully flashed to 1080p ROM from the same PC, so RK30 driver is installed.
I even managed to make a new hole for the reset button - it was at the wrong side (chinese precision :)
When I hold reset button and connect MX1 to my PC (OTG port), PC detects the device (if RKBatchTool.exe is started). The previously installed RK30 driver pops up and it says "working properly". But RKBatchTool.exe still doesn't detect MX1. After a while big android robot with some buttons in the belly shows on the screen (some recovery mode?).
What am I doing wrong? Any idea what else I could try?

Thanks!
deepmind
 
Posts: 2
Joined: Mon Jan 07, 2013 1:37 pm

Re: Sv: bricked mx1?

Postby lexan76 » Sun Jan 13, 2013 4:01 pm

deepmind wrote:Hi,
I bricked my iMito MX1. It loops at boot (at "iMito MX series" text). I followed the instructions how to unbrick it, but no luck so far.
I previously successfully flashed to 1080p ROM from the same PC, so RK30 driver is installed.
I even managed to make a new hole for the reset button - it was at the wrong side (chinese precision :)
When I hold reset button and connect MX1 to my PC (OTG port), PC detects the device (if RKBatchTool.exe is started). The previously installed RK30 driver pops up and it says "working properly". But RKBatchTool.exe still doesn't detect MX1. After a while big android robot with some buttons in the belly shows on the screen (some recovery mode?).
What am I doing wrong? Any idea what else I could try?

Thanks!

Have you tried flashing the finless.1.5? It includes another flash tool, maybe it can detect your stick?

Skickat från min Transformer TF101 via Tapatalk 2
lexan76
 
Posts: 29
Joined: Tue Dec 25, 2012 5:15 pm

Re: bricked mx1?

Postby deepmind » Mon Jan 14, 2013 5:49 am

Hi!
Yes! That worked. Now the old method works, too. This driver is weird :)
Thanks!
deepmind
 
Posts: 2
Joined: Mon Jan 07, 2013 1:37 pm

Re: bricked mx1?

Postby DiZet » Mon Feb 04, 2013 12:14 pm

Tried both Flash tools and get the same error “download file failed”. If I connect it to tv it shows “No Signal”. Is there something wrong with hardware? It worked fine and after it got stuck and I had to remove dc to restart, it is not working anymore. Anyone knows what could be the problem ? Tried different firmwares and all give the same result

Log:
17:57:23 987 Rockchip Batch Tool v1.5.3.0 start run
17:57:43 675 **********Restore Start Total<1>**********
17:57:43 679 <Layer 8-3> Test Device Start
17:57:43 684 <Layer 8-3> Test Device Success
17:57:43 688 <Layer 8-3> Lowerformat Device Start
17:58:45 821 <Layer 8-3> Lowerformat Device Success
17:58:45 831 <Layer 8-3> Test Device Start
17:58:45 841 <Layer 8-3> Test Device Success
17:58:45 854 <Layer 8-3> Check Chip Start
17:58:45 864 <Layer 8-3> Check Chip Success
17:58:45 876 <Layer 8-3> Get FlashInfo Start
17:58:45 880 <LAYER 8-3> INFO:FlashInfo: 0 0 0 1 0 10 10 28 40 2 1
17:58:45 886 <Layer 8-3> Get FlashInfo Success
17:58:45 893 <Layer 8-3> Prepare IDB Start
17:58:45 897 <LAYER 8-3> INFO:CS(1) (8192MB) (HYNIX)
17:58:45 973 <Layer 8-3> Prepare IDB Success
17:58:45 984 <Layer 8-3> Download IDB Start
17:59:47 771 <Layer 8-3> Download IDB Success
17:59:47 783 <Layer 8-3> Reset Device Start
17:59:48 794 <Layer 8-3> Reset Device Success
17:59:48 806 <Layer 8-3> Wait For Loader Start
17:59:50 010 <Layer 8-3> Wait For Loader Success
17:59:50 014 <Layer 8-3> Test Device Start
18:00:41 122 <Layer 8-3> Test Device Success
18:00:41 134 <Layer 8-3> Download Firmware Start
18:01:08 580 <LAYER 8-3> ERROR:RKA_Param_Check-->Memcmp failed,Read(0)
18:01:08 590 <LAYER 8-3> ERROR:DownloadImage-->RKA_Param_Check failed
18:01:08 601 <Layer 8-3> Download Firmware Fail
18:01:08 612 **********Restore Done Success<0> Fail<1> Time<204922>ms**********
DiZet
 
Posts: 1
Joined: Mon Feb 04, 2013 11:51 am

Re: bricked mx1?

Postby bolsa1 » Sun Feb 10, 2013 3:39 pm

I can get mine to flash by holding in reset button then plugging it in.. but when it goes to reset usb, I have to do it again really fast to get it to recognize the imito so it can write the firmware..
even after all that and I get a success message, it still wont boot..
first time after full 'recover' process I see the android bootloader writing data cache sdcard etc.. then nothing..

What do I need to do to fix mine?
bolsa1
 
Posts: 29
Joined: Wed Dec 05, 2012 10:05 am

Re: bricked mx1?

Postby rooter » Fri May 24, 2013 11:41 am

please help us, I have the same problem as the above people. It was bricked during update process from micro sd on the update.img file. I tried to flash using the tools provided by the finless rom and can't even though its detected. I tried resetting using pins 8 and 9 and is detected fine but it just says failed every single time. Please help me
rooter
 
Posts: 4
Joined: Tue Dec 11, 2012 4:46 pm

Re: bricked mx1?

Postby rooter » Sun May 26, 2013 9:04 am

bump
rooter
 
Posts: 4
Joined: Tue Dec 11, 2012 4:46 pm

Next

Return to MX1

Who is online

Users browsing this forum: No registered users and 1 guest