What worked for me and what hasn't

Re: What worked for me and what hasn't

Postby Tropicalia » Thu Dec 06, 2012 10:26 pm

At the moment i have two devices connected to the iMito MX1. These are:

Behringer U-Control UCA222 USB Audio Interface
http://www.behringer.com/FR/Products/UCA222.aspx
I can wholeheartedly recommend this device to those looking for a external soundcard to use with their iMito. Sure, its almost half the price of the stick itself but has great features such as optical out and other connectivity options. Good, clear sound, headphone input with volume knob and according to some also works similarly to a cheap USB Dac although i havent really noticed any benefits in the audio on that level myself.

Also using the Logitech K400 mentioned in this thread earlier. That too a sweet piece of hardware. Both periphals worked right out of the box.

I have tried to get my Huawei E353 3g modem (Hilink) working. No success so far. :( Does the Imito even have support for external 3g? If so what might i be doing wrong? Only tried it connected to the different ports but it doesnt get detected.

Overall... Very happy with this device.
Tropicalia
 
Posts: 1
Joined: Thu Dec 06, 2012 10:01 pm

Re: What worked for me and what hasn't

Postby Daytpn56 » Fri Dec 07, 2012 12:08 pm

I'm sure its a fine product for those that don't have "tin ears" like myself. A $2 sound card with 3.5mm mini plug to left/right RCA jacks into a $20 LaPai stereo amp is more my speed. I'm sure those with musically tuned ears will appreciate your review.
Daytpn56
 
Posts: 10
Joined: Sat Nov 10, 2012 1:06 am


Return to Working Peripherals

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest